Schlagwort-Archive: IPv6

[GELÖST] Unitymedia VPN Probleme wg DSlight (IPv4 / IPv6)

Kurz vorab: es gibt hunderte verschiedene Möglichkeiten, warum ausgehende VPN Verbindungen von einem Unitymedia Anschluss gestört sein können. Diese Erklärung bezieht sich auf die Konstellation, dass das VPN Gateway auf der Gegenseite (nennen wir es einmal „Arbeitgeber“) schon natives IPv6 unterstützt, die Verbindung aber sehr langsam ist und wieder abbricht.

Bitte hinterlasse einen Kommentar, ob diese Lösung in Deinem Fall erfolgreich war bzw. ob Du andere Ansätze hast das Problem zu lösen.

Solltest Du auch mit diesen Tipps keine stabile / performante VPN Verbindung aufbauen können, ist eine Umstellung Deines Anschlusses auf IPv4 notwendig:

Ich, Niclas Roth, bin Unitymedia Technik- und Vertriebspartner. Für die hessischen Unitymedia Kunden: gerne kannst Du Dich bei dem Umstellwunsch auf IPv4 an mich wenden: 06127-999823 bzw. [email protected]

Diese Erklärung wurde mir von einem Mitarbeiter der Firma Symantec zukommen lassen, der nach eifriger Recherche diese Lösung entwickelt hat. Danke, A.S.! Sie sollte für alle von Unitymedia angebotenen Router / Modems / MTA identisch sein, also Technicolor TC 7200, Connect Box, Fritzbox 6360, Fritzbox 6490, Fritzbox 6320, Cisco etc.

 

[..] An dieser Stelle war bei mir das Problem das die VPN Verbindung in das Unternehmen zwar aufgebaut und auch gehalten wurde, dass allerdings keine Applikation eine brauchbare Verbindung aufbauen konnte und selbst ein Browsen im Intranet Minuten für eine Seitenaufbau benötigt hat. Nach einiger Calls mit unserer IT wurde mir mitgeteilt das ein native IPv6 Verbindung unterstützt wird und das Problem anderweitig zu suchen ist.

Lange rede kurzer Sinn Ich habe mich dann selber mal auf die Suche gemacht und habe herausgefunden das das Problem primär an der Fragmentierung der IP Pakete lag was dann typischerweise auf die falsche Größe der Jumbo Frames (MTU Setting) zurückzuführen ist.

Nachfolgend nun kurz die Befehle um das Client seitig zu prüfen und ggf. auch zu ändern (die Fritzbox lässt das nicht zu)

Auslesen der MTU Einstellungen:

netsh interface ipv4 show subinterface – zeigt die Einstellungen aller Adapter für IPv4
netsh interface ipv6 show subinterface – zeigt die Einstellungen aller Adapter für IPv6
netsh interface ipv4 show subinterface „Local Area Connection“ – zeigt die Einstellungen für eine speziellen Adapter

Setzten der Einstellungen für einen speziellen Adapter zum Beispiel dem virtuellen VPN Adapter, wichtig ist dabei das der VPN Tunnel vorab gestartet wird.

netsh interface ipv4 set subinterface „Local Area Connection* 15“ mtu=1280 – wobei Local Area Connection* 15“ der Name des virtuellen Adapters ist

netsh interface ipv6 set subinterface „Local Area Connection* 15“ mtu=1280 – 1280 ist dabei die Einstellung die das Gateway benötigt, will heissen das kann variieren.

Wenn mann den MTU wert permanent setzten möchte ist je nach Betriebsystem noch der paremeter – store=persistent – anzufügen.

Bsp.: netsh interface ipv6 set subinterface „$AdapterName“ mtu=1400 store=persistent

Hinweis: Bitte verwende diese Einstellungen nur, wenn Du weisst, was Du tust. Eine Datensicherung bzw. ein Wiederherstellungspunkt unter Windows hat noch nie geschadet! Bitte die Anleitung vorab durchlesen und verstehen, d.h. auch die notwendigen Konfigurationsdaten von der IT der Gegenseite (Arbeitgeber) im Vorfeld zu erfragen.

Garantien, Gewährleistung bzw. Support werden von mir bei diesem Thema nicht angeboten. Wenn Du nicht nicht sicher bist, was gemacht werden soll, kontaktiere bitte den IT Profi Deines Vertrauens.

Update 25. Juni 2018

Für Mac OS X:

Testen MTU Size:

ping -D -s 1500 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 1500 data bytes
ping: sendto: Message too long

Einstellung über Netzwerk -> Auswahl Adapter -> weitere Optionen -> Hardware

PS4 Netzwerkprobleme bei Onlinespielen (Destiny, Battlefiled, usw.):

Auch hier hilft eine Anpassung der MTU über PS4 Einstellungen -> Netzwerk: manuelle Konfiguration (bei mir 1450)

(Danke, Udo!))

[Gelöst] Unitymedia: Problem mit Technicolor TC 7200 Modem / Zugriffe auf bestimmte Websiten funktionieren nicht (Update)

Vorab schon einmal: bitte hinterlasse eine Nachricht in den Kommentaren, ob die hier vorgestellten Lösungen bei Dir Erfolg gebracht haben oder nicht. Danke!

Weitere Lösungsansätze (z.B. für die Kombination Horizon Recorder und TC7200) befinden sich übrigens auch in den Kommentaren zu diesem Beitrag!

In seltenen Fällen melden Kunden des Anbieters Unitymedia, dass diese auf einige Internetseiten nicht zugreifen können, in mir bekannten Fällen waren Internetseiten wie Google.de und T-Online.de nicht aufrufbar – auch ein paar Computerspiele konnten nicht online genutzt werden. Andere Seiten können ohne Probleme geöffnet werden.

Update 3.12.2013: Diese Änderungen scheinen die Ursache der Probleme zu beheben – bitte zuerst ausschließlich diese Änderungen durchführen und testen!

Smartphones und Tablets mit dem Android Betriebsystem konnten von den bislang von uns genannten Tipps nicht provitieren – dafür wurde jetzt anscheinend aber eine Lösung gefunden.

Die ersten Tests und Rückmeldungen von unseren Kunden deuten darauf hin, dass die Zugriffs- und Stabilitätsprobleme mit diesen Änderungen behoben werden oder zumindest deutlich verbessern:

Öffne dafür ein Browserfenster (z.B. Internet Explorer oder Firefox) und gehe auf die Konfigurationsoberfläche des TC 7200 – dort diese Zugangsdaten eingeben:

  • Benutzername: admin
  • Passwort: admin

Sobald man auf der Konfigurationsoberfläche ist Grundeinstellung auswählen und dort auf Lokales Netzwerk (LAN) wechseln

Auf dieser Seite bitte einen statischen IPv6 DNS Server eintragen:

  • IPv6 DNS Server 1: 2620:0:ccc::2
  • IPv6 DNS Server 2: 2620:0:ccd::2

Ich bitte um eine Rückmeldung in den Kommentaren auf dieser Seite, ob diese Änderung Besserung gebracht hat.

Sollte diese Vorgehensweise keinen Erfolg gebracht haben, bitte diese Änderungen durchführen:

Die Probleme lassen sich evtl. beheben, in dem in den Netzwerkeinstellungen das „Internetprotokoll Version 6 (TCP/IPv6)“ deaktiviert wird.

Hier ein Beispiel der Konfiguration auf einem Windows 7 PC, bei anderen Betriebssystemen oder wenn der Laptop / PC per WLAN angeschlossen ist, kann dies evtl. etwas anders aussehen:

  • Klick mit der rechten Maustaste auf das Netzwerksysbol / WLAN Symbol
  • „Netzwerk- und Freigabecenter öffnen“ anklicken
  • In diesem Beispiel: „LAN-Verbindung“ anklicken
  • „Eigenschaften“ anklicken (Administrator Rechte notwendig!)
  • Den Haken vor: „Internetprotokoll Version 6 (TCP/IPv6)“ entfernen (der Haken vor Internetprotokoll Version 4 muss stehen bleiben!)
  • Mit OK bestätigen, alle Fenster schließen

Bitte geben Sie über die Kommentarfunktion eine Rückmeldung, ob das Problem dadurch gelöst wurde und welche Seiten bei Ihnen Betroffen waren / sind.

Update 22.11.2013: Bitte erst durchführen, wenn das Eintragen der IPv6 DNS Server Adressen (oberster Tipp vom 3.12.13) nicht erfolgreich war.

In einem anderen Fall war es auch notwendig die IPv4 DNS Server Adressen zu ändern:

  • Klick mit der rechten Maustaste auf das Netzwerksysbol / WLAN Symbol
  • „Netzwerk- und Freigabecenter öffnen“ anklicken
  • In diesem Beispiel: „LAN-Verbindung“ anklicken
  • „Eigenschaften“ anklicken (Administrator Rechte notwendig!)
  • Den Eintrag „Internetprotokoll Version 5 (TCP/IPv4)“ anklicken, dann auf den Button Eigenschaften klicken
  • „IP-Adresse“ automatisch beziehen“ muss aktiv sein, weiter unten bitte „Folgende DNS-Serveradressen verwenden“ auswählen.
  • Bei „Bevorzugter DNS-Server:“ bitte „8.8.8.8“ eintragen (die Punkte sind schon vorgegeben!)
  • Bei „Alternativer DNS-Server:“ bitte „8.8.4.4“ eintragen.
  • Mit OK bestätigen, alle Fenster schließen

Betroffene Websiten waren u.a.: facebook.com, google.de, google.com, heise.de, microsoft.de, microsoft.com

Betroffen sind alle die Internetseiten, welche auf eine DNS Abfrage mit einer IPv6 Adresse antworten.